VMware

VCenter 6 Installation schlägt fehl

Ich habe heute in meiner Testumgebung ein VCenter 6 Installieren wollen. Frische Installation, keine Migration o.ä.
Dazu habe ich einen neuen Windows Server 2016 aufgesetzt und durchgepatcht. Anschließend die Installation des VCenters mit der embedded Datenbank gestartet und nach einiger Zeit kam folgendes:

"Vmware VirtualCenter failed fistboot. 
VirtualCenter registration with Component Manager failed. 
Please referer to vSphere documentation to troubleshoot or Please contact VMWare Support"

Nach ein bisschen Suchen hier und da stellt ich dann heraus, dass auf dem virtuellen Server keine VMWare Tools installiert sein dürfen. Also die Tools deinstalliert, neugestartet und schon lief die Installation ohne Probleme durch…

VMWARE VI-Client Shotcut mit Authentifizierung

Bei den meisten dürfte inzwischen die Authentifierung beim Zugriff auf den ESX-Host oder das vCenter über das AD laufen. Damit man nun mit einem Doppelklick die Verbindung zum vCenter-Server inkl. Authentifizierung aufbauen kann muss man dem VI-Client nur zwei kleine Parameter mitgeben:

-passthroughAuth -s SERVERNAME

Das sieht dann so aus:

Großes Upgrade im heimischen „Lab“ – PT2

Wie angekündigt, geht es nun los.

Als ich aus dem Urlaub wieder kam habe ich erstmal das Paket von der Nachbarin abgeholt und das Gäuse aus dem Keller geholt. Schon konnte es losgehen 🙂

Erstmal das Board ins Gehäuse setzen:

dann CPU und Lüfter drauf…

zuletzt das Netzteil rein, um die Stromrechung nicht mehr als nötig zu blasten ist es eins mit Effizienz 80+ geworden, dazu noch die 3TB Festplatte als Zwischenspeicher

und fertig. Nun den USB Stick dran und den ESXi installieren:

Hat auch geklappt. Aber: Er startet nicht automatisch vom Stick. Er will immer erst von der HDD starten, was natürlich nicht geht.

Da muss ich nochmal schauen. Vielleicht bekommt er dann doch eine kleine interner Platte mit 250GB oder so. Aber eigentlich muss es ja auch vom Stick gehen…

Großes Upgrade im heimischen „Lab“

Wie die meisten vermutlich schon gesehen haben, bin ich verrückt. Denn bei mir daheim steht ein „kleiner“ ESXi Host. Da die Maschinen diesen Host aber an sein Limit treiben und mir das nicht-RAID schon länger ein Dorn im Auge ist, gibt es nun ein Upgrade.

Der aktuelle ESXi Host wird dabei weiter verwendet, nämlich als Storage. Der neue Host wird in der ersten Ausbaustufe schonmal 16GB RAM (also 6GB mehr als der aktuelle) haben und somit hoffentlich um einiges Performanter sein. Außerdem wird in dem Storage nur noch in RAIDs gearbeitet, was hoffentlich auch die Geschwindigkeit etwas steigert. Denn wie wir wissen, sind die Perfomanceengpässe immer am PlattenRAM 😉

Als wird es Storage vorerst drei Datastores geben:

RAID1 2 x 400GB
RAID1 2 x 1TB
RAID5 3 x 3TB
RAID1 2x 500GB

Daraus ergibt sich eine Gesamtkapazität von 7,4TB. Das 500GB RAID1 ist nur eine Überlegung, denn die Platten fliegen hier noch so rum und Backupspace braucht man immer…

Als ESXi Host wird folgende Konfiguration verwendet:

MoBo  Intel Dq67OW
RAM 2x8GB Corsair DDr
NIC Intel Pro 10/100/1000 (2x)
CPU Intel Pentium G630 – mal sehen ob die reicht. Aber ein i5 war mir zu teuer

Auf dem Host wird natürlich die neuste Version ESXi 5.1 betrieben und auf dem Storage ein FreeNAS. Dieses wird dem Host per NFS oder iSCSI (dazu tendiere ich) die Platten zur Verfügung stellen.

Um den Stromverbruach realtiv gleich zu halten wird die nicht Astaro Firewall in Zukunft virtualisiert betrieben. Die drei NICs werden also alle genutzt für 

1x Storage
1x WAN
1x LAN 

Die neue Konfiguration wird mir mehr Sicherheit bieten, denn wenn so eine Platte abraucht sind die Daten weg und müssen mit viel Arbeit aus dem Backup wiederhergestellt werden. Außerdem ist es hoffentlich ein Schritt nach vorne was die Performance betrifft. Un wenn ich irgenwann mal total durchdrehe kann ich mit einem zweiten Host auch noch HA, FT etc betreiben…

Mehr dazu wenn die Teile da sind 🙂

Neues Geschäftsjahr – Neue Hardware

Kaum hat am 1.4. das neue Geschäftsjahr in vielen Firmen begonnen hält bei mir neue Hardware einzug bzw. umzug.

Ich habe den Netgear FS726T den ich hier hatte in mein Mini-RZ gebracht und nun den ESXi über Gigabit an den Rest des Netzwerkes angebunden. Hier werkelt dafür nun ein unmanaged 16Port Switch.

Außerdem kann der Netgear VLANs was in Zukunft wichtig wird, wenn nämlich mein neues ESXi kommt und die Firewall virtualisiert wird. Dann muss das Internet aus dem Keller nach oben ins Mini-RZ. Dies geschieht dann über ein extra VLAN.

Dafür gabs auch gleich neue Hardware für den Keller:

IMG-20120404-00021

Zu guter letzt habe ich gestern mein MacBook Air bei Apple bestellt. Mal gucken ob ich das mag. Aber im Vergleich zu den aktuellen Ultrabooks (auch preislich gesehen) ist es echt attraktiv.

crond auf ESXi 4.0 startet nicht

Ich habe gestern mein ghettoVCB (Beitrag folgt) in die crontab eingetragen und danach den cron neugestartet – dachte ich. Leider habe ich übersehen, dass der crond nicht gestartet ist.

Heute morgen habe ich es dann erstmal mit der original crontab versucht 🙁 Ergebnislos.

Also google angeworfen und realativ schnell fündig geworden

I see „busybox crond“  when i do a  „ps | grep cron“

odd that yours doesn’t but /var/run/crond.pid should be correct , try killing that pid , ( process at your own risks here )

in my case , after I edit the root crontab and I kill cron, I can’t start it back buy calling „busybox crond“. I had to:

ln -s /bin/busybox /bin/crond

/bin/crond

In order for this to survive a reboot , I just added in my rc.local  ( example job )

/bin/kill $(cat /var/run/crond.pid)

echo ‚* * * * * touch /tmp/aa‘ >> /var/spool/cron/crontabs/root

ln -s /bin/busybox /bin/crond

/bin/crond

Dieser Tipp aus der VMware Community hat alles wieder gerade gerückt. Danke an Dan!

 

Quelle: VMware Communities

[ESXi4] Unable to access a file since it is locked

Gestern Abend habe ich auf unserem Produktiven ESXi eine Maschine exportiert um sie auf dem Test-System einzuspielen.

Dabei ist der VMware Converter ins trudeln gekommen und hat den ersten Versuch abgebrochen, der zweite lief einwandfrei.

Heute morgen wollte ich die Maschine dann wieder anstarten, da gabs eine Überraschung: Die Maschine könne nicht gestartet werden weil die virtuelles Festplatte (also das VMDK-File) gelockt sei.

Ein kurzer Blick ins Logfile sagte mir:

vmware-9.log:Nov 26 10:55:47.313: vmx| AIOGNRC: Failed to open ‚/vmfs/volumes/4e089681-4cfc1988-d41a-001b21b01f58/HS1SW001/HS1SW001-flat.vmdk‘ : Failed to lock the file (67) (0x2013).
vmware-9.log:Nov 26 10:55:47.313: vmx| DISKLIB-VMFS : „/vmfs/volumes/4e089681-4cfc1988-d41a-001b21b01f58/HS1SW001/HS1SW001-flat.vmdk“ : failed to open (Failed to lock the file): AIOMgr_Open failed. Type 3
vmware-9.log:Nov 26 10:55:47.313: vmx| DISKLIB-LINK : „/vmfs/volumes/4e089681-4cfc1988-d41a-001b21b01f58/HS1SW001/HS1SW001.vmdk“ : failed to open (Failed to lock the file).
vmware-9.log:Nov 26 10:55:47.313: vmx| DISKLIB-CHAIN : „/vmfs/volumes/4e089681-4cfc1988-d41a-001b21b01f58/HS1SW001/HS1SW001.vmdk“ : failed to open (Failed to lock the file).
vmware-9.log:Nov 26 10:55:47.313: vmx| DISKLIB-LIB : Failed to open ‚/vmfs/volumes/4e089681-4cfc1988-d41a-001b21b01f58/HS1SW001/HS1SW001.vmdk‘ with flags 0xa Failed to lock the file (16392).
vmware-9.log:Nov 26 10:55:47.313: vmx| DISK: Cannot open disk „/vmfs/volumes/4e089681-4cfc1988-d41a-001b21b01f58/HS1SW001/HS1SW001.vmdk“: Failed to lock the file (16392).
vmware-9.log:Nov 26 10:55:47.313: vmx| [msg.disk.configureDiskError] Reason: Failed to lock the file.—————————————-

da ist was im argen. Mit einem

# touch *
touch: HS1SW001-flat.vmdk: Device or resource busy

also geprüft welche files alle betroffen sind, im endeffekt wars nur die HS1SW001-flat.vmdk

Dann mit

# lsof | grep HS1SW001-flat.vmdk
Cartel ID: 5111 fd: 98 Type: 12 file name: HS1SW001-flat.vmdk

überprüft von welchem Prozess das File gelockt ist und den Prozess gekillt.

# kill 5111

Und schon war wieder alles in bester Ordnung!

KB-Link: http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=10051

Windows 8 Developer Version zum Download

Seit heute Morgen kann die Entwicklerversion von Windows 8 heruntergeladen werden.
Cashy hat da mehr zu geschrieben und auch die Links gepostet:

Link

Achja, VMware 7 geht nicht, Version 8 soll aber funktionieren. VirtualBox auch!

Vom Blackberry gepostet

Hardware maintenance

So, nach einer kurzen Downtime von 30 Minuten hat mein ESX jetzt (Die hatte er schon nach 10 Minuten…) 10GB RAM zur Verfügung.

IMG00140-20101120-1744

Die letzte Ausbaustufe sind 16GB, das dauert aber noch etwas. Inzwischen liebäugle ich mit einer SSD für die Systemplatten der Maschinen…Mal gucken was das neue Jahr so bringt an Hardware 😉

VMExplorer

So, jetzt habe ich mal fix den VMExplorer geprüft, Sicherungen laufen alle wie sie sollen, doch was ich nicht wusste: Die Snapshots die er erstellt sind flat. D.h. Die Sicherung ist so groß, wie die Platte der VM, nicht so groß wie der Inhalt.

2010-11-15 122838

 

Da kommen dann mal schnell über 300G zusammen, ich glaube ich muss mal ein SAN bauen *gg* (Nein, das ist kein Overkill…nur ein wenig)