Windows Server

Alles rund um Windows Server. Von W2k3 bis 2008R2

Neues Geschäftsjahr – Neue Hardware

Kaum hat am 1.4. das neue Geschäftsjahr in vielen Firmen begonnen hält bei mir neue Hardware einzug bzw. umzug.

Ich habe den Netgear FS726T den ich hier hatte in mein Mini-RZ gebracht und nun den ESXi über Gigabit an den Rest des Netzwerkes angebunden. Hier werkelt dafür nun ein unmanaged 16Port Switch.

Außerdem kann der Netgear VLANs was in Zukunft wichtig wird, wenn nämlich mein neues ESXi kommt und die Firewall virtualisiert wird. Dann muss das Internet aus dem Keller nach oben ins Mini-RZ. Dies geschieht dann über ein extra VLAN.

Dafür gabs auch gleich neue Hardware für den Keller:

IMG-20120404-00021

Zu guter letzt habe ich gestern mein MacBook Air bei Apple bestellt. Mal gucken ob ich das mag. Aber im Vergleich zu den aktuellen Ultrabooks (auch preislich gesehen) ist es echt attraktiv.

mit TMG redirect auf /owa

Gestern habe ich mich endlich mal dran gemacht und auf unserer TMG eine neue Regel erstellt, die Anfragen auf unser OWA via http entgegen nimmt und dann auf die https-Adresse umleitet. Weiterhin ist es nicht mehr nötig den kompletten Pfad also inkl /owa anzugeben.

Zunächst wird der OWA-Listener um den Port 80 erweitert und der gesamte HTTP-Traffict auf HTTPS umgeleitet:

Dabei stieß ich auf das Problem, dass der installierte IIS Port 80 für sich beanspruchte und ein Binding auf 0.0.0.0:80 hatte. Nachdem ich den IIs über die Management-Konsole auf Port 8066 umgebogen habe funktionierte der Listener auch einwandfrei.

Nun konnte eine neue Regel kreiert werden beziehungsweise können wir einfach die Veröffentlichungsregel für das OWA duplizieren:

Die neue Regel wird dann aber auf „Deny“ und „Redirect to <OWA-Adresse>“ gestellt:

Weiterhin muss die Authentifizierung abgeschaltet werden:

 

Als letztes müsse die Pfade bereinigt werden, es darf lediglich „/“ eingetragen sein:

Fertig und eigentlich wars ja auch ganz einfach!

ActiveSync durch Astaro WAF?

In Bezug auf meinen Beitrag zum Thema OWA durch die ASG mit WAF bereitstellen wurde ich angeschrieben und gefragt, wie man denn Active Sync durch die WAF bekommt. Meine Antwort war leider negativ: Ich habe keine Ahnung. Damals habe ich (aus historischen Gründen) ActiveSync via Port 9443 und als NAT-Rule gemacht, heute läufts über ne TMG.

Weiß jemand von euch, wie die korrekten Einstellungen sind? Wenn ich was in Erfahrung bringe, wird es natürlich an dieser Stelle ein weiteres Bilderbuch geben!

Lync vs. Trixbox

Es ist zum Mäuse melken. Seit mindestens 2 Wochen sitze ich daran und versuche meinem Lyncserver eine Trixbox-VM als PSTN-Gateway unterzujublen.

Das Ergebnis:
incoming calls: Positiv
outgoing calls: Negativ

Eingehende Anrufe werden von der Trixbox sauber durchgeroutet – mein Lync-Client klingelt, man kann auch abnehmen. Bidirektionale Kommunikation ist möglich – alles toll 🙂

Ausgehende Anrufe sind laut CSCP auch möglich…

2011-07-26 185508

Auf der Trixbox sehe ich nichts – also mal ins Log geschaut. (Natürlich nicht erst heute… aber man gibt ja nicht gleich auf…)

2011-07-26 185655

Aus dem Log resultierte die Frage: Warum Port 5070?

Ich habe dann etwas gegoogelt, leider Erfolglos. Als wenn das nicht reichen würde, habe ich im Eventlog noch folgende Meldung gefunden:

2011-07-26 184306

„The Gateway peer, 192.168.17.22 , is not responding to an OPTIONS request sent by the Mediation Server service“

Super Sache. Die allwissende Müllhalde hat dazu ergeben: Seit dem CU2 schickt Lync zum Verifizieren der Erreichbarkeit des PSTN-Gateways einen OPTIONS request. Und zertifizierte Gateways antworten natürlich auch… super. (Quelle)

Tja, dann werde ich in nächster Zeit mal das Web nach einer Lösung für dieses Problem absuchen… oder hat von euch jemand eine?

Es liegt kein Problem vor…

Da überraschte meine WSUS mich heute morgen aber, als ich mal wieder ins Eventlog schaute und sah, dass er kein Problem hat:

2011-07-26 065526

Im ersten Moment schon eine lustig Meldung – kennt man ja von Windows sonst nicht…

TMG 2010: Scriptausführung abbrechen?

Als ich heute unsere Sharepointseite publishen wollte überraschte mich die TMG mit dieser Frage. „Do you want to continue running scripts on this page?“

tmg prob 1

Kurz gegooglet und es war klar: der IE9 war schuld. Nicht nur, dass er den Hostblog verunstaltet hat er legt auch MS eigene Produkte lahm.

Noch einmal kurz kontrolliert: Ja der IE9 wurde via WSUS installiert.

tmg prob 2

Also runter damit, einmal neustarten. Und schon ist alles wieder im alten look.

tmg prob 3

Drucker kann nicht hinzugefügt werden: 0x00000006

Seit einziger Zeit konnte ich keine Drucker mehr per GPO verteilen und auch das manuelle Hinzufügen funktionierte nicht. Es kam immer der sehr aussagekräftige Fehler:

drucker

 

Nach etwas googlen stellt sich heraus, dass dies ein bekannter Fehler ist, und dieser nur Auftritt wenn man den Printserver per Namen anspricht.

Tatsächlich: Sobald ich den Server per IP ansprach funktionierte es. Ich habe nun die GPOs von DNS auf IP geändert und es läuft, aber der Sinn der Sache ist das ja nicht (man bedenke mal IPv6, da möchte ich keine IP Adresse mehr tippern)

Microsoft Security Essentials 2.0 per GPO steuern

Wer im größeren Umfeld MSE2.0 nutzt (z.B. bis zu 10 Clients gewerblich an einem SBS) der wird sich über die „zentrale Verwaltbarkeit“ von MSE freuen. Auch wenn sie nicht so komfortabel ist wie z.B. McAfee ePo Server o.ä. so ist die kostenlos.

Über Registry-Settings die via GPP verteilt werden lassen sich ohne Probleme die wichtigsten Funktionen einrichten.

HIER gibt es einen ausführlich Blog-Artikel zu dem Thema!