Sicheres WLAN mit PEAP und WPA2-Enterprise

Bei mir zu Hause werkelt noch eine uralte (meine erste) Fritzbox als Accesspoint. Alles andere ist inzwischen modernisiert worden.

Die Firewall (Sohos UTMv9) läuft virtuell und der Switch ist ein stromsparender D-LINK Eco Switch der im Gegensatz zu seinem Vorgänger (HP 2524) zwar nicht mehr managebar ist, aber deutlich weniger Strom verbraucht und Gigabit hat.

(mehr …)

Danke DHL…

Vor ca. drei Wochen hat meine Freundin etwas bestellt. Der Versand erfolgte am nächsten Tag mit DHL. Nach ungefähr einer Woche fragte man sich dann, wo das Paket denn sei… Es stellte sich heraus, dass es leider beim Transport so beschädigt wurde, dass es erst von DHL neu verpackt werden muss. Na super.

Die Verkäuferin war so nett ein zweites Paket auf die Reise schicken. Das erste, kaputte, sollten wir dann zurück gehen lassen bzw. die Annahme verweigern. Das war dummerweise ein Umstand der bei mir nicht ankam. Und so kamen letzten Freitag beide Pakete gleichzeitig an. Da nur ich zu Hause war, nahm ich sie beide an. Großer Fehler….

Als Sie nach Hause kam, war die Verwirrung groß, warum ich denn beide Pakete angenommen hatte. Nagut dachte ich mir: Es wurde ja nicht von Ihr angenommen daher kann man sicher nachträglich die Annahme verweigern….

Wie bin ich da nur drauf gekommen? Auf jeden Fall rief ich bei DHL an und hatte ein ca. 10 minütiges Gespräch mit einer mehr oder weniger freundlichen Mitarbeiterin. 

Der Inhalt: 

(mehr …)

Eigene Cloud…

Wie der eine oder andere weiß, bin ich ja etwas verrückt und betreibe auch eine kleine eigene „Cloud“-Infrastruktur. 

Im Grunde umfasst das ganze derzeit zwei ESXi Hosts, einer im Rechenzentrum und einer zu Hause auf dem File-, E-Mail und Webserver laufen. 

Durch Replikation und Backups ist das ganze mittlerweile auch meiner Meinung nach gut gesichert, sodass eigentlich so schnell nichts weg kommen kann. 

Damit hatte ich mich dann von öffentlichen Providern für E-Mail und Webservices abgekapselt und auch ein Offsite-Backup läuft auf meine eigene Maschine. Das einzige, was mir noch ein Dorn im Auge ist, ist Dropbox. Da habe ich leider noch keine passende alternative gefunden.

(mehr …)

FB#17: Fotos vom Altstadtfest

In diesem Album findet ihr ein paar Fotos vom Altstadtfest dieses Jahr. Da ich nicht viel mit der Kamera unterwegs war, eigentlich hauptsächlich der Auftritt von Marti Fischer 😉

Klick

Vorsicht: VTIGER CRM und PHP 5.4.4

Falls ihr VTIGER CRM im Einsatz habt (in meinem Fall 5.4.0) und überlegt eure Webserver auf PHP Version 5.4.4 zu updaten, so solltet ihr das zumindest für den VTIGER Server noch sein lassen. Zum einen wird eine gobale Variable referenziert die in PHP 5.4.4 nicht unterstützt wird und mit einer SPLIT Funktion gibt es auch ein paar Probleme. Weitere Infos dazu in der Mailingliste:

http://lists.vtigercrm.com/pipermail/vtigercrm-commits/2012-December/051312.html 

und hier:

http://loginshell.de/vtiger-und-php-5-4-problem/

Achja, ich musste wieder downgraden um VTIGER lauffähig zu haben 🙁

mod_gnutls mit SSL kommt man immer auf die gleiche Seite

 

 

Sollte bei euch der Fehler auftauchen, dass trotz aktivierten mod_gnutls immer nur eine Webseite via SSL ansprechbar ist, und ihr beim restart vom apache2 vielleicht sogar noch folgende Fehlermeldung bekommt:

 

Restarting web server: apache2[Thu May 23 11:46:15 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence

[Thu May 23 11:46:15 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence

[Thu May 23 11:46:15 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence

 … waiting [Thu May 23 11:46:16 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence

[Thu May 23 11:46:16 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence

[Thu May 23 11:46:16 2013] [warn] _default_ VirtualHost overlap on port 443, the first has precedence

.

dann schaut mal in eure  /etc/apache2/ports.conf rein, das sollte so aussehen: 

 

 

NameVirtualHost *:443

<IfModule mod_gnutls.c>

Listen 443

</IfModule>

Bei mir war noch mod_ssl drin und das hackte dazwischen. Einfach mal auskommentieren, sodass für SSL nur noch der Teil oben steht.

Migration auf eine SSD

Seit ich mein MacBook habe arbeitet meine Freundin mit meinem alten Dell D820. Das Arbeitstier hat aber seine beste Zeit auch schon hinter sich und ist nicht mehr der schnellste. 

Um doch noch etwas Leistung herauszukizeln habe ich damals dem Gerät schon 4GB RAM spendiert und nun folgt eine SSD.

Nach der Installation des Samsung Migration Wizard musste ich erstmal feststellen: Zuuuu viel Daten auf der Platte. Die SSD fasst 111GB – auf der C-Partition der 250GB HDD waren aber 140GB. Also wurde erstmal mit Robocopy weggeräumt.

Anschließend habe ich den Samsung Data Migration Wizard nochmal angeworfen – leider ohne Erfolg. Jeweils bei 97% zeigte er an:

Super Fehlermeldung – und auch so Aussagekräftig. Also fix von der Acronis DVD gebotet und den Punkt „Festplatte Klonen“ ausgeählt – auch hier: Pustekuchen. Man kann keine Partitionen sondern nur – wie der Name sagt – ganze Platten. Also lief es darauf hinaus, dass ich ein Backup der C-Partition erstellt und das dann auf die SSD restored habe – fertig. Hätte ich das mal gleich gemacht!

Jetzt rennt die alte Kiste wie ein neuer!

Get-Exchange Certificate -Server ‚SERVER‘ : Access is denied

Heute Morgen wollte ich mir ein Problem mit der Generierung des OAB anschauen und bin in der EMC auf folgende Fehlermeldung gestoßen:

Um das ganze zu verifizieren habe ich dann den Befehl nochmal von hand in der EMS ausgeführt – leider das gleiche Ergebnis:

Get-ExchangeCertificate -Server ‚SERVER‘

Bei der Fehlermeldung schoss mir sofort in den Kopf, dass ich vor zwei Wochen eine neue GPO erstellt habe mit der ich einem User Rechte auf allen Maschinen eingeräumt hatte. Anscheinend habe ich damit aber die Gruppe der lokalen Admins auf den Servern etwas geleert…

Was definitiv fehlte, war das „Exchange Trusted Subsystem“, also einfach „Add“ wählen und wieder rein mit ihm…

Und sofort funktionierte der Befehl wieder wie gewünscht:

Der Fehler war, dass ich beim Anlegen einer GPO mit der Einstellung „Restricted Group Access“ nur den „neuen“ User, den ich eintragen wollte, ausgewählt habe und nicht die Mitglieder der jeweils lokalen Gruppe „Administrators“.

Dadurch wurden alle bis auf den neuen User aus der Gruppe gelöscht. 

Wenn man aber den Eintrag „Administrators“ hinzufügt, werden die Mitglieder der lokalen Administrator-Gruppe erhalten. Muss man wissen!